summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>2022-05-09 13:10:18 +0300
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-05-10 13:53:43 +0200
commit1ddda31f14e0aa89057203b61793d75275e8cf34 (patch)
treedc289624c026e55dde24f7682950becf50e91c7d /meson.build
parent68fd4b3c9137ddf2416f9dc82d3e1964fcbd5bfd (diff)
meson: Use new project_*_root() functions
meson.source_root() and meson.build_root() are deprecated. Use meson.project_source_root() and meson.project_build_root() instead. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index b892ba84..10ad8c5c 100644
--- a/meson.build
+++ b/meson.build
@@ -17,8 +17,8 @@ project('libcamera', 'c', 'cpp',
# git version tag, the build metadata (e.g. +211-c94a24f4) is omitted from
# libcamera_git_version.
libcamera_git_version = run_command('utils/gen-version.sh',
- meson.build_root(),
- meson.source_root()).stdout().strip()
+ meson.project_build_root(),
+ meson.project_source_root()).stdout().strip()
if libcamera_git_version == ''
libcamera_git_version = meson.project_version()
endif
@@ -160,7 +160,7 @@ endif
# Create a symlink from the build root to the source root. This is used when
# running libcamera from the build directory to locate resources in the source
# directory (such as IPA configuration files).
-run_command('ln', '-fsT', meson.source_root(), meson.build_root() / 'source')
+run_command('ln', '-fsT', meson.project_source_root(), meson.project_build_root() / 'source')
configure_file(output : 'config.h', configuration : config_h)