summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 00000000..d1e186ad
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,15 @@
+project('libcamera - supporting complex camera pipelines', 'cpp',
+ version : '0.1',
+ license : 'LGPL 2.1+')
+
+inc = include_directories('include')
+
+subdir('lib')
+subdir('test')
+
+pkg_mod = import('pkgconfig')
+pkg_mod.generate(libraries : libcamera,
+ version : '1.0',
+ name : 'libcamera',
+ filebase : 'camera',
+ description : 'Complex Camera Support Library')