summaryrefslogtreecommitdiff
path: root/src/py/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/py/libcamera/meson.build')
-rw-r--r--src/py/libcamera/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index a3388c63..0a7b65f3 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -30,6 +30,18 @@ pycamera_sources += custom_target('py_gen_controls',
output : ['py_control_enums_generated.cpp'],
command : [gen_py_control_enums, '-o', '@OUTPUT@', '@INPUT@'])
+gen_py_formats_input_files = files([
+ '../../libcamera/formats.yaml',
+ 'py_formats_generated.cpp.in',
+])
+
+gen_py_formats = files('gen-py-formats.py')
+
+pycamera_sources += custom_target('py_gen_formats',
+ input : gen_py_formats_input_files,
+ output : ['py_formats_generated.cpp'],
+ command : [gen_py_formats, '-o', '@OUTPUT@', '@INPUT@'])
+
pycamera_deps = [
libcamera_public,
py3_dep,