summaryrefslogtreecommitdiff
path: root/src/py/libcamera/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2023-11-08 13:44:20 +0000
committerNaushir Patuck <naush@raspberrypi.com>2023-11-29 09:05:38 +0000
commit0455bbbf518cc834bd72ac65e13c9ed40bf21f3c (patch)
tree97fec38bd5b40cf14e411f425fd31261b4124351 /src/py/libcamera/meson.build
parentbba4ec63c4b0699b7f7ffb20e4f37af2b996d355 (diff)
build: controls: Rework how controls and properties are generated
Add support for using separate YAML files for controls and properties generation. The mapping of vendor/pipeline handler to control file is done through the controls_map variable in include/libcamera/meson.build. This simplifies management of vendor control definitions and avoids possible merge conflicts when changing the control_ids.yaml file for core and draft controls. With this change, libcamera and draft controls and properties files are designated the 'libcamera' vendor tag. In this change, we also rename control_ids.yaml -> control_ids_core.yaml and property_ids.yaml -> property_ids_core.yaml to designate these as core libcamera controls. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/py/libcamera/meson.build')
-rw-r--r--src/py/libcamera/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index 1c3ea184..31af63ec 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -28,11 +28,15 @@ pycamera_sources = files([
# Generate controls
-gen_py_controls_input_files = files('../../libcamera/control_ids.yaml')
+gen_py_controls_input_files = []
gen_py_controls_template = files('py_controls_generated.cpp.in')
gen_py_controls = files('gen-py-controls.py')
+foreach file : controls_files
+ gen_py_controls_input_files += files('../../libcamera/' + file)
+endforeach
+
pycamera_sources += custom_target('py_gen_controls',
input : gen_py_controls_input_files,
output : ['py_controls_generated.cpp'],
@@ -41,9 +45,13 @@ pycamera_sources += custom_target('py_gen_controls',
# Generate properties
-gen_py_property_enums_input_files = files('../../libcamera/property_ids.yaml')
+gen_py_property_enums_input_files = []
gen_py_properties_template = files('py_properties_generated.cpp.in')
+foreach file : properties_files
+ gen_py_property_enums_input_files += files('../../libcamera/' + file)
+endforeach
+
pycamera_sources += custom_target('py_gen_properties',
input : gen_py_property_enums_input_files,
output : ['py_properties_generated.cpp'],