summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorHan-Lin Chen <hanlinchen@chromium.org>2022-04-27 22:09:27 +0800
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-10 00:22:36 +0300
commitfcb0ea001a2d3350068410c3bd2f940694a339a0 (patch)
tree1c62b437e8191237560f77812e9ed8089df0665d /src/libcamera/meson.build
parentc70323e4941542202c34f4fde7d340d1f62d6c9c (diff)
libcamera: Introduce YamlParser as a helper to parse yaml files
Introduce YamlParser as a helper to convert contents of a yaml file to a tree based structure for easier reading, and to avoid writing parser with raw yaml tokens. The class is based on libyaml, and only support reading but not writing a yaml file. The interface is inspired by Json::Value class from jsoncpp: http://jsoncpp.sourceforge.net/class_json_1_1_value.html Signed-off-by: Han-Lin Chen <hanlinchen@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 26912ca1..f8e18e03 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -46,6 +46,7 @@ libcamera_sources = files([
'v4l2_pixelformat.cpp',
'v4l2_subdevice.cpp',
'v4l2_videodevice.cpp',
+ 'yaml_parser.cpp',
])
libcamera_sources += libcamera_public_headers
@@ -66,6 +67,7 @@ subdir('proxy')
libdl = cc.find_library('dl')
libgnutls = cc.find_library('gnutls', required : true)
libudev = dependency('libudev', required : false)
+libyaml = dependency('yaml-0.1', required : true)
if libgnutls.found()
config_h.set('HAVE_GNUTLS', 1)
@@ -126,6 +128,7 @@ libcamera_deps = [
libgnutls,
liblttng,
libudev,
+ libyaml,
]
# We add '/' to the build_rpath as a 'safe' path to act as a boolean flag.