summaryrefslogtreecommitdiff
path: root/src/ipa/rkisp1/algorithms/meson.build
diff options
context:
space:
mode:
authorDaniel Semkowicz via libcamera-devel <libcamera-devel@lists.libcamera.org>2022-07-13 10:43:09 +0200
committerJacopo Mondi <jacopo@jmondi.org>2022-07-14 17:06:47 +0200
commit9d79a6b6c64e0b6281391c3277af68210d434460 (patch)
tree91af0bb582ca557010a5dd7038c3a290ec80b7b0 /src/ipa/rkisp1/algorithms/meson.build
parent5504e573f27d3d4aba6f903e01075fcc27700d3e (diff)
ipa: rkisp1: Add AF algorithm basing on common AfHillClimbing class
Rockchip ISP AF block allows calculation of sharpness and luminance in up to three user defined windows. If no windows are set, there are some default settings applied for the first window and exposed through the driver. For each frame, use the sharpness value calculated for this default window and feed the hill climbing algorithm with them. Then set the lens position to value calculated by the algorithm. Signed-off-by: Daniel Semkowicz <dse@thaumatec.com>
Diffstat (limited to 'src/ipa/rkisp1/algorithms/meson.build')
-rw-r--r--src/ipa/rkisp1/algorithms/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/rkisp1/algorithms/meson.build b/src/ipa/rkisp1/algorithms/meson.build
index 7ec53d89..81addcc9 100644
--- a/src/ipa/rkisp1/algorithms/meson.build
+++ b/src/ipa/rkisp1/algorithms/meson.build
@@ -1,6 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
rkisp1_ipa_algorithms = files([
+ 'af.cpp',
'agc.cpp',
'awb.cpp',
'blc.cpp',