summaryrefslogtreecommitdiff
path: root/src/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorStefan Klug <stefan.klug@ideasonboard.com>2024-08-20 16:51:43 +0200
committerStefan Klug <stefan.klug@ideasonboard.com>2024-09-23 16:42:45 +0200
commit2e936455ae2eaa761f37b8678e0f62f419a4b4b3 (patch)
treef546bb86614a3be69243a5de0132dae97075e453 /src/ipa/libipa/meson.build
parent6b67094cd231548df3a42d72351ca9e8841b7033 (diff)
ipa: libipa: Add generic Interpolator class
The MatrixInterpolator is great for interpolation of matrices for different color temperatures. It has however one limitation - it can only handle matrices. For LSC it would be great to interpolate the LSC tables (or even polynomials) using the same approach. Add a generic Interpolator class based on the existing MatrixInterpolator. This class can be adapted to any other type using partial template specialization. Signed-off-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'src/ipa/libipa/meson.build')
-rw-r--r--src/ipa/libipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/libipa/meson.build b/src/ipa/libipa/meson.build
index eff8ce26..2c2712a7 100644
--- a/src/ipa/libipa/meson.build
+++ b/src/ipa/libipa/meson.build
@@ -7,6 +7,7 @@ libipa_headers = files([
'exposure_mode_helper.h',
'fc_queue.h',
'histogram.h',
+ 'interpolator.h',
'matrix.h',
'matrix_interpolator.h',
'module.h',
@@ -21,6 +22,7 @@ libipa_sources = files([
'exposure_mode_helper.cpp',
'fc_queue.cpp',
'histogram.cpp',
+ 'interpolator.cpp',
'matrix.cpp',
'matrix_interpolator.cpp',
'module.cpp',