summaryrefslogtreecommitdiff
path: root/src/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorDaniel Semkowicz <dse@thaumatec.com>2023-01-19 09:41:07 +0100
committerJacopo Mondi <jacopo.mondi@ideasonboard.com>2023-09-04 14:08:51 +0200
commit6d52f4005069c7759e5a6360069fee3d42235d39 (patch)
tree7a959fe6513a04153577e092690fc642cb1d77ea /src/ipa/libipa/meson.build
parente78832cf91a81539f6188cf38739c3547b74684b (diff)
ipa: Add base class defining AF algorithm interface
Define common interface with basic functions that should be supported by Auto Focus algorithms. Signed-off-by: Daniel Semkowicz <dse@thaumatec.com>
Diffstat (limited to 'src/ipa/libipa/meson.build')
-rw-r--r--src/ipa/libipa/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/ipa/libipa/meson.build b/src/ipa/libipa/meson.build
index 016b8e0e..0cfc551a 100644
--- a/src/ipa/libipa/meson.build
+++ b/src/ipa/libipa/meson.build
@@ -1,5 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
+subdir('algorithms')
+
libipa_headers = files([
'algorithm.h',
'camera_sensor_helper.h',
@@ -8,6 +10,8 @@ libipa_headers = files([
'module.h',
])
+libipa_headers += common_ipa_algorithms_headers
+
libipa_sources = files([
'algorithm.cpp',
'camera_sensor_helper.cpp',
@@ -16,6 +20,8 @@ libipa_sources = files([
'module.cpp',
])
+libipa_sources += common_ipa_algorithms_sources
+
libipa_includes = include_directories('..')
libipa = static_library('ipa', [libipa_sources, libipa_headers],