summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-08-03 22:55:49 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-08-05 18:26:36 +0300
commit9f513439b6896d1a33c91a400bd02b7b8829feb6 (patch)
treeac0e0e76e5ac060a2abdef4215771e1413f7daf3 /meson.build
parent0bb8afc9ac9c6fadfae676932ba47f4a1fe33871 (diff)
meson: Drop gcc 8 support
The libcamera CI has retired gcc 8 testing with the end of life of Debian Buster at the end of June 2024. As gcc 8 isn't tested anymore, we can't guarantee it will keep building libcamera correctly. Drop its support. If anyone still has a compelling use case for gcc 8 support for libcamera, we will investigate how to restore it in CI. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 316abdb8..59293e47 100644
--- a/meson.build
+++ b/meson.build
@@ -146,16 +146,8 @@ if cc.get_id() == 'clang'
endif
if cc.get_id() == 'gcc'
- if cc.version().version_compare('<8')
- error('gcc version is too old, libcamera requires 8.0 or newer')
- endif
-
- # On gcc 8, the file system library is provided in a separate static
- # library.
if cc.version().version_compare('<9')
- cpp_arguments += [
- '-lstdc++fs',
- ]
+ error('gcc version is too old, libcamera requires 9.0 or newer')
endif
# gcc 13 implements the C++23 version of automatic move from local